Working with FreeBSD’s ports

Posted on October 22, 2011. Filed under: Uncategorized | Tags: , |

  1. Fetch and update your ports collection:

    portsnap fetch
    portsnap extract # first time only
    portsnap update # subsequently

    (this takes some time)

  2. Find the packages you want to install/upgrade:

    Find out-of-date packages:

    pkg_version -v

    Find a new package:

    whereis port-i-want

  3. Change to the directory for the port you want to install:

    cd /usr/ports/path-to/port-i-want

  4. Install it:

    make install clean

  5. Upgrading installed ports using portmaster:

    portmaster needs to be installed before use:

    cd /usr/ports/ports-mgmt/portmaster
    make install clean

    You can list all the installed ports and search for updates using the -L option:

    portmaster -L

    All the installed ports can be upgraded at once:

    portmaster -a

  6. Cleaning up:

See Using the Ports Collection in the FreeBSD Handbook for more details

Liked it here?
Why not try sites on the blogroll...